Supported Browsers

In this article, you’ll learn about web browsers that work with CallRail and Lead Center.

Compatible browsers

CallRail has been tested with and supports the latest version of the following browsers:

  • Google Chrome.
  • Mozilla Firefox.
  • Microsoft Edge.

We also support the following non-evergreen browsers:

  • Safari (versions 17+, available on macOS Sonoma and newer).

Incompatible browsers 

We do not support the following browsers:

  • Internet Explorer 11. CallRail dropped support on March 1, 2021.
  • Microsoft Edge 18. Microsoft dropped support for EdgeHTML on March 9, 2021.
Was this article helpful?
0 out of 0 found this helpful

Articles in this section

See more
Ask the Community
Find best practices, post, and learn from CallRail users.
CallRail Support Hours
Weekdays 9:00am - 9:00pm EST